Severe Weather Events Layer – Unstable Globally

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 17:33 UTC

Identified

We’re currently investigating an issue affecting the Severe Weather Events layer, which is unstable across all regions. Our team is actively working to identify the root cause and restore full functionality.

We’ll provide updates as more information becomes available. Thank you for your patience.
Posted Jun 24, 2025 - 14:35 UTC
This incident affected: Web Application and API (Events API).