Global thunderstorm probability fields unavailable

Incident Report for Tomorrow.io

Resolved

Global thunderstormProbability data has returned to the platform and API. We will backfill some missed data, and future runs will have the fix in place to prevent further missing data.
Posted Apr 21, 2026 - 15:10 UTC

Monitoring

An error in the calculation of our global thunderstorm probability caused missing data, which in turn caused API requests including thunderstormProbability to fail. We have deployed a fix for this issue and are backfilling data to resolve these requests.
Posted Apr 21, 2026 - 10:00 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application, Tiles, Timeline).