Stale Forecasted Precipitation Data for Some Locations Globally

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 07:37 UTC

Update

A fix has been applied, and forecasted precipitation data should now be current.
Posted Aug 29, 2025 - 03:13 UTC

Investigating

We are currently investigating an issue that is resulting in stale forecasted precipitation data for some locations globally. No estimated return to normal functionality is available at this time.
Posted Aug 29, 2025 - 01:15 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.