Rainfall accumulation data missing in CONUS region

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 19:39 UTC

Identified

We've identified an issue with precipitation accumulation over the CONUS region, generally in the 18-48 hour timesteps. Our team is working on a resolution.
Posted Jul 07, 2025 - 08:00 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Insights API) and Web Application.