CBAM Customers: Stale data

Incident Report for Tomorrow.io

Resolved

CBAM data was temporarily stale due to resource issues and has been restored, thank you for your patience!
Posted Jul 01, 2026 - 11:28 UTC

Investigating

We are currently investigating this issue.
Posted Jul 01, 2026 - 10:59 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application).