Delayed or missing lightning data over CONUS

Incident Report for Tomorrow.io

Resolved

The data flow issue that was causing a temporary delay in displaying recent and current lightning strikes on the Weather Intelligence Platform has been resolved. Lightning data is now updating as expected.

We appreciate your patience while we worked to restore full functionality. Please reach out if you experience any further issues.
Posted Jul 16, 2025 - 07:43 UTC

Monitoring

Data flow appears to be returning to normal. Current and recent lightning strikes are now displaying as expected on the Weather Intelligence Platform.
Posted Jul 16, 2025 - 04:33 UTC

Investigating

A data flow issue is causing a temporary delay in how recent and current lightning strikes are being displayed on the Weather Intelligence Platform.
Posted Jul 16, 2025 - 04:15 UTC
This incident affected: Web Application.