Degraded Quality of Precipitation Products (Real-Time and Forecast) across Italy

Incident Report for Tomorrow.io

Resolved

The data feed is now completely current.
Posted Jun 19, 2026 - 14:25 UTC

Monitoring

Data is now returning from the upstream source and our application is backfilling missing data. Data should be current shortly. We will continue to monitor until data is completely current.
Posted Jun 19, 2026 - 12:09 UTC

Investigating

We are investigating an upstream data issue which is resulting a degraded quality of precipitation (real-time and forecast) across Italy.
Posted Jun 18, 2026 - 22:07 UTC
This incident affected: API (Timeline API, Map API, Insights API, Alerts API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).