Stale Realtime & Nowcast Data for Precipitation Products in the Americas (Non-Radar Areas)

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 19:58 UTC

Identified

Precipitation products over South and North America (excluding radar-covered areas over CONUS) are currently experiencing stale realtime and nowcast data. Our team is investigating and will provide updates as available.
Posted Mar 27, 2025 - 06:49 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.