Delayed Data Affecting Real-Time and Nowcast Precipitation

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 13:19 UTC

Identified

We are currently experiencing delays in upstream satellite data. As a result, some customers may experience degraded or delayed real-time and nowcast precipitation data in non-radar regions across Europe, Africa, and the Middle East.

Our team is actively monitoring the upstream data feed. Data has begun flowing again, and we expect service to return to normal within approximately 30 minutes.

We will provide another update once the recovery is complete.
Posted Jul 13, 2026 - 11:22 UTC
This incident affected: API (Timeline API) and Web Application - Platform (Web Application).