Variety of Missing Aviation-Related Products (including METARs and Government TAFs)

Incident Report for Tomorrow.io

Resolved

Upstream data has resumed and has returned to normal.
Posted Dec 14, 2025 - 09:40 UTC

Identified

An upstream data outage is resulting in a variety of aviation-related products to be stale or missing on the Tomorrow.io Platform, including: missing information on the airports layer, stale/old information on the airports panel including stale METARs, stale SIGMETs and AIRMETs, and stale Government TAFs.
Posted Dec 14, 2025 - 05:19 UTC
This incident affected: Web Application - Platform (Web Application).