CBAM LATAM, IL Timeline Update
Incident Report for Tomorrow.io
Resolved
This incident has been resolved.
Posted Dec 02, 2024 - 20:41 UTC
Identified
A potential interruption in the CBAM LATAM timeline has been identified toward the end of the current forecast period. We expect continuity to be restored in a few hours.

We are monitoring the situation closely and will provide updates as necessary.
Posted Dec 02, 2024 - 15:17 UTC