Degraded Precipitation Data: UP, Nextgen

Incident Report for Tomorrow.io

Resolved

The issue affecting precipitation data across portions of North and South America has been resolved as of approximately 12:15 UTC.

All affected services are now operating normally. We will continue to monitor performance to ensure stability.
Posted Aug 18, 2026 - 12:20 UTC

Investigating

Since 09:50 UTC, we have been experiencing degraded precipitation data across portions of North and South America where radar coverage is unavailable.

Affected products:

*Classic: UP-Caribbean, UP-South-America, UP-USA, and UP-Global
*Next Gen: UP-Caribbean, UP-Central-America, UP-South-America, UP-USA, and UP-Global

Affected forecast range: Real-time and nowcast.

Our team is actively investigating the issue and will provide an update as more information becomes available.
Posted Aug 18, 2026 - 09:50 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application, Tiles, Timeline).