Google Cloud upstream issues

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 16:09 UTC

Monitoring

Google Cloud is reporting improvements and we are monitoring for a full recovery.
Posted Jul 18, 2025 - 16:04 UTC

Identified

An issue upstream with Google Cloud is producing intermittencies to several API and platform products, as well as TAF publication. Our team is working to mitigate the impacts.
Posted Jul 18, 2025 - 15:15 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.