UP Nowcast (CONUS) Serving Stale Data Due to Upstream Delay

Incident Report for Tomorrow.io

Resolved

UP Nowcast in the CONUS region served stale data due to a delay in an upstream data feed.

The issue occurred between 08:00 UTC and 10:00 UTC.
Posted Jul 05, 2026 - 10:00 UTC

Identified

UP Nowcast in the CONUS region is currently serving stale data because of a delay in the upstream data feed. As a result, UP Nowcast outputs may not reflect the latest conditions.
Posted Jul 05, 2026 - 08:00 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API).