Unified Precipitation nowcasts not completing

Incident Report for Tomorrow.io

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 15:59 UTC

Identified

Unified precipitation nowcasts are intermittently not completing. Impacts will be intermittently missing precipitation forecasts, mostly in the t+2h and +3h timesteps. We have identified the issue and are working on a fix.
Posted May 21, 2026 - 12:00 UTC
This incident affects: API (Timeline API, Map API) and Web Application - Platform (Tiles, Timeline).