Increased Latency in Maps API Tiles

Incident Report for Tomorrow.io

Resolved

This issue was resolved.
Posted May 31, 2025 - 20:00 UTC

Identified

We have identified and are working on an issue that is causing latency in Maps API tiles. Tiles were/are slower than usual.
Posted May 31, 2025 - 17:00 UTC
This incident affected: API (Map API).