We’ve rolled back the recent changes and will revisit the deployment on the week of August 4th. We’ll provide another update as soon as we resume or have more information to share. Thanks for your patience!
As always, If you encounter any issues or unexpected data behavior, please reach out to support@tomorrow.io.
Posted Jul 31, 2025 - 11:28 UTC
Update
We’ve entered an extended rollout phase for our upgraded backend weather database. This update improves ingestion speed, forecast accuracy, and alignment between timeline and tile data.
Following the successful controlled rollout on July 24 and internal validation of unit conversion fixes, we are now gradually expanding the rollout throughout the week. The system remains under active observation.
What to Expect: Short-term inconsistencies in timeline data may still occur as final updates are deployed.
We are continuously monitoring API behavior, tile delivery, and unit accuracy.
Users may notice improved consistency between forecast tiles and timeline responses.
Looking ahead: If stability continues, we plan to transition the system to full 24/7 availability by the end of the rollout window. Any changes to this plan will be communicated here.
If you encounter any issues or unexpected data behavior, please reach out to support@tomorrow.io.
Posted Jul 27, 2025 - 09:59 UTC
Monitoring
Start: July 24, 2025 at 03:30 UTC Planned End: July 24, 2025 at 10:30 UTC Status: Monitoring Components Affected: Timeline API
We’re continuing the controlled rollout of our upgraded backend weather database, aimed at improving ingestion speed, forecast accuracy, and alignment between timeline and tile data.
This phase is scheduled for Thursday, July 24 between 03:30–10:30 UTC, pending confirmation of today’s unit conversion fix. The system will be closed over the weekend following this window.
Looking ahead: If no major issues arise, we plan to keep the system open 24/7 starting next week. Any changes to this plan will be communicated here.
What to Expect:
* Potential for limited, short-term data inconsistencies during the rollout window. * Active monitoring of API behavior, tile delivery, and unit accuracy. * Ongoing updates will be posted here throughout the day.
If you experience any irregularities, please reach out to support at support@tomorrow.io