Insights and monitors producing stale data

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 16:30 UTC

Investigating

An issue is causing recently-created insights and monitors to not update. These insights are currently producing stale data. Our engineers are investigating.
Posted Aug 12, 2026 - 12:46 UTC
This incident affected: Web Application - Platform (Monitors (Insights), Alerts, Custom Vector Events feeds) and API (Insights API, Alerts API).