Eumetsat MET-9 Satellite Feed is Stale

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Satellite and Nowcast precipitation data are populating and functioning as expected across the previously impacted areas:
Europe (eastern Europe, in non-radar covered areas)
Israel (on-radar covered areas)
India (western India)
Global (central Asia, Indian Ocean)
Posted Jan 20, 2026 - 02:42 UTC

Investigating

There is an upstream data issue that is causing stale satellite data; MET-9 SEVIRI Level 1.5 and Level 2 data unavailable until further notice. Investigation is ongoing.

This is causing stale satellite data and degraded nowcast precipitation products for the following areas:
Europe (eastern Europe, in non-radar covered areas)
Israel (on-radar covered areas)
India (western India)
Global (central Asia, Indian Ocean)
Posted Jan 20, 2026 - 01:52 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API).