Intermittent issues with realtime observations in the current conditions layer

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 17:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2025 - 17:20 UTC

Identified

We're having issues integrating realtime observations into current conditions layers. Realtime data, including parameters such as temperature, winds, and cloud ceilings, are degraded. Our engineers are working on a fix.
Posted Jul 21, 2025 - 14:30 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.