Degraded Quality of Precipitation Products (Real-Time and Forecast) across Israel

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 03:23 UTC

Update

Our team has implemented a fix, and we are monitoring for stability.
Posted Jul 15, 2026 - 23:57 UTC

Monitoring

Our team has implemented a fix, and we are monitoring for stability.
Posted Jul 15, 2026 - 22:54 UTC

Identified

We have identified an issue which is resulting in a degraded quality of precipitation data (real-time and forecast) across Israel. Our team is currently working on a fix for this issue.
Posted Jul 15, 2026 - 22:19 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline, Weather Reports).