Missing Westbound North Atlantic Aviation Tracks

Incident Report for Tomorrow.io

Resolved

Issue is resolved, Westbound North Atlantic Aviation Tracks are visibile on the platform.
Posted Apr 29, 2025 - 07:36 UTC

Identified

We are currently investigating two related issues:

-No New Data from RadarBox
New flight data from our provider, RadarBox, is currently unavailable. We've reached out to their support team and will update once we have an estimated resolution time.

Outdated Flight Data Displayed
Some older flight data is still showing despite the outage. Our team is investigating a possible connection service issue.
Posted Apr 28, 2025 - 13:14 UTC

Investigating

An upstream data outage is causing missing westbound North Atlantic aviation tracks. We will update this incident as more information becomes available.
Posted Apr 27, 2025 - 22:40 UTC
This incident affected: Web Application.