Degraded Quality of Precipitation Products (Real-Time and Forecast) for Many Locations Without Radar Coverage

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 18:42 UTC

Monitoring

We have started receiving data again and we are monitoring for restoration into the affected regions
Posted Jul 16, 2026 - 17:57 UTC

Investigating

Since approximately 20:23 UTC, an upstream satellite issue has been resulting in a degraded quality of precipitation products (real-time and forecast) for locations without radar coverage globally. Classic precipitation data is affected across the CONUS, Caribbean, South America, along with additional locations globally.
Posted Jul 15, 2026 - 20:23 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application, Tiles, Timeline).