Possible Delay in Monitor and Alert Updates

Incident Report for Tomorrow.io

Resolved

The issue has been mitigated and system functionality should now be restored. We are continuing to investigate the root cause to ensure long-term stability.
Posted May 28, 2025 - 12:46 UTC

Monitoring

We’re currently investigating an issue with our monitoring system that may be causing slight delays in alert and insight updates.

Some monitors or alerts may not refresh on their usual 15-minute update cycle. In most cases, this should resolve automatically and may not result in noticeable disruption, but we’re actively monitoring the situation to ensure reliability.

We’ll share another update once this is fully resolved. Thank you for your patience.
Posted May 28, 2025 - 09:27 UTC
This incident affected: Web Application and API (Insights API, Alerts API, Notifications API).