Global precipitation processing issues

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 10:30 UTC

Monitoring

A fallback has been implemented to prevent the data from being missing, but precipitation data is still degraded over Africa, the Middle East, and Indian Ocean.
Posted Apr 21, 2025 - 13:36 UTC

Update

Real-time and forecasted precipitation data continues to remain degraded or missing across Africa, the Middle East, Indian Ocean, and also across some portions of Europe (mainly eastern Europe). We are continuing to work on operational stability for precipitation products.
Posted Apr 17, 2025 - 23:42 UTC

Identified

Real-time and forecasted precipitation data has again become degraded or missing across Africa, the Middle East, and Indian Ocean. We are continuing to work on operational stability for precipitation products.
Posted Apr 17, 2025 - 19:55 UTC

Monitoring

The recent issue resulting in degraded or missing real-time and forecasted NextGen precipitation data across Africa, the Middle East, and Indian Ocean has been resolved. We are continuing to monitor to ensure stability of the precipitation data.
Posted Apr 17, 2025 - 17:42 UTC

Identified

An upstream data outage has resulted in real-time and forecasted NextGen precipitation data to become degraded or missing across Africa, the Middle East, and Indian Ocean. Further updates will be provided as they become available.
Posted Apr 17, 2025 - 16:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 21:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 16, 2025 - 17:06 UTC

Identified

Global realtime and short-term forecast precipitation data is having processing issues and may be intermittently unavailable in many areas.
Posted Apr 16, 2025 - 15:02 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.