Upstream Outage - degraded or missing precipitation data for portions of eastern Europe, western/central Asia (including India), and eastern Africa

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 14:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 11:30 UTC

Identified

An upstream data outage is again resulting in degraded real-time and forecasted precipitation data for portions of eastern Europe, western/central Asia (including India), and eastern Africa where there is no supplemental radar data.
Posted Mar 24, 2026 - 23:19 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application, Tiles, Timeline).