Real-Time and Forecast Data is Stale

Incident Report for Tomorrow.io

Resolved

A fix has been implemented and data is returning to normal. After a period of monitoring, this issue is now resolved.
Posted Jul 13, 2025 - 10:23 UTC

Identified

The source of this issue has been identified, and a fix will be implemented shortly.
Posted Jul 13, 2025 - 09:44 UTC

Investigating

We are currently investigating an issue that is resulting in real-time and forecast data to become stale for many locations. Updates regarding a resolution will be provided as they become available.
Posted Jul 13, 2025 - 09:29 UTC
This incident affected: API (Timeline API, Map API, Historical API, Events API, Insights API, Alerts API, Notifications API) and Web Application.