Stale Nowcast Data: CONUS, Europe, Central America, Southeast Asia

Incident Report for Tomorrow.io

Resolved

This incident has been resolved, and nowcast data is now current for the FOCUS regions of CONUS, Europe, Central America, and Southeast Asia.
Posted Dec 25, 2025 - 21:41 UTC

Monitoring

An upstream outage has delayed nowcast data for the FOCUS regions of CONUS, Europe, Central America, Southeast Asia . A fix has been deployed, and we will monitor until data is current.
Posted Dec 25, 2025 - 15:39 UTC
This incident affected: API (Timeline API, Insights API, Alerts API) and Web Application.