Upstream stale/missing aviation data continues

Incident Report for Tomorrow.io

Resolved

The upstream data issue has been resolved, and icing data is now fully available within the Tomorrow.io Platform.
Posted Jun 14, 2026 - 23:27 UTC

Investigating

While some icing data has returned, upstream data issue is continuing to cause stale or missing aviation data. We are monitoring the feed and will report when it has become stable.
Posted Jun 14, 2026 - 17:07 UTC
This incident affected: Web Application - Platform (Aviation).