Degraded Real-Time and Forecasted Precipitation over Portions of Europe, Africa, and the Middle East

Incident Report for Tomorrow.io

Resolved

Upstream data has stabilized and service has returned to normal. We have not observed any further impact following the maintenance activity, and this incident is now resolved.

We will continue to monitor our upstream providers as part of our normal operations.
Posted Jun 30, 2026 - 19:00 UTC

Monitoring

Data has been restored, but upstream maintenance continues, so we will continue to monitor through through 11:00 UTC on July 1 or until we receive word that the maintenance has completed.
Posted Jun 30, 2026 - 18:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 30, 2026 - 17:44 UTC

Identified

Upstream data maintenance is resulting in degraded real-time and forecasted precipitation over non-radar regions of Europe, Africa, and the Middle East. This issue is expected to continue intermittently through 11:00 UTC on July 1.
Posted Jun 30, 2026 - 17:42 UTC
This incident affected: API (Timeline API, Map API, Historical API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).