CBAM Hydro data for Israel delayed
Incident Report for Tomorrow.io
Resolved
CBAM hydro data for Israel is back to normal.
Posted Jan 01, 2025 - 12:55 UTC
Investigating
CBAM hydro data for Israel is currently delayed. Model forecast information is not refreshing and may be stale until a new model run is received.
Posted Jan 01, 2025 - 03:00 UTC
This incident affected: Web Application.