NextGen Customers: Degraded Nowcast for NextGen Precipitation (All Regions)

Incident Report for Tomorrow.io

Resolved

The issue causing degraded Nowcast performance for NextGen Precipitation across all UP NextGen regions has been resolved.

The impact was related to an upstream transition, and a fix has been implemented. Systems are now operating normally.

Thank you for your patience.
Posted Mar 04, 2026 - 15:07 UTC

Identified

We are currently investigating an issue of degraded Nowcast performance for NextGen Precipitation across all UP NextGen regions.

Our team has identified an upstream transition and is actively working on a fix.

We will provide an update as soon as more information is available, thank you for your patience±
Posted Mar 04, 2026 - 13:37 UTC
This incident affected: API (Timeline API) and Web Application - Platform (Web Application).