CBAM Hydro data for Israel delayed
Incident Report for Tomorrow.io
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 19:11 UTC
Monitoring
The forecast for CBAM IL are outdated 48 hours into the past and future. We're actively monitoring.
Posted Jan 02, 2025 - 10:43 UTC
This incident affected: API (Timeline API, Map API) and Web Application.