Timeline Data Unavailable/Displays Inconsistently

Incident Report for Tomorrow.io

Resolved

A fix has been deployed, and after a period of monitoring, this issue appears to have been resolved.
Posted Apr 21, 2026 - 15:18 UTC

Investigating

There is an issue with timeline data either displaying intermittently for some users, or displaying as “Data is not available” for other users. Our engineers are working to identify the root cause for this issue.
Posted Apr 21, 2026 - 13:36 UTC
This incident affected: Web Application - Platform (Web Application, Timeline).