Stale or Degraded Quality of Real-Time and Forecasted Precipitation Data for Many Locations Globally
Incident Report for Tomorrow.io
Resolved
This issue has been resolved.
Posted May 27, 2024 - 15:39 UTC
Update
A fix has been implemented to once again restore timeliness of real-time and forecasted precipitation data across several areas, including the United States. We will continue to monitor, and update once more as this issue becomes fully resolved.
Posted May 27, 2024 - 10:00 UTC
Update
Real-time and forecast precipitation data is once again stale or exhibiting degraded quality across the United States. Work continues on a fix for the issue, and we will provide updates regarding a resolution as they become available.
Posted May 27, 2024 - 08:41 UTC
Monitoring
A fix has been implemented, and the previous issue with significantly stale or missing real-time and forecasted precipitation has been resolved across the United States. Precipitation data across global regions is expected to return to normal functionality very shortly as well.
Posted May 27, 2024 - 05:01 UTC
Update
Real-time and forecasted precipitation data is now significantly stale or missing for many locations globally. Our engineering team is actively investigating the issue at present, and further updates will be provided as they become available.
Posted May 27, 2024 - 02:42 UTC
Investigating
We are currently investigating an issue that is resulting in real-time and forecasted precipitation data to become stale or exhibit degraded quality for many locations globally, specifically for those areas within the United States, Europe, Japan, Brazil, and Australia. Updates regarding a resolution will be provided as they become available.
Posted May 27, 2024 - 00:47 UTC
This incident affected: API (Timeline API, Map API, Historical API) and Web Application.