The affected forecast data has been updated, and the issue is now resolved. All systems are operating normally.
There was no significant impact expected from the earlier delay, but we will continue to monitor closely.
Thank you for your patience!
Posted May 28, 2025 - 09:09 UTC
Identified
Users in the CONUS region may notice slightly outdated forecast data for the 18–48 hour lead time window. Short-range forecasts (0–18h) remain current and unaffected.
We are investigating a delay in upstream data delivery that caused the 00Z (00:00 UTC) forecast cycle to be stale. Subsequent short-range cycles (02Z–04Z, or 02:00–04:00 UTC) have completed successfully. As a result, longer-range (18–48h) forecasts are currently based on the previous cycle and may be slightly degraded.
The next full 48-hour update is expected at 06Z (06:00 UTC). We are actively monitoring and will update this page if user impact changes.
Posted May 28, 2025 - 05:56 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.