Reporting of European Severe Weather Events Potentially Delayed or Missing

Incident Report for Tomorrow.io

Resolved

Resolved: Severe Weather Events in EU are populating in the platform as expected.
Posted Jun 07, 2026 - 22:00 UTC

Investigating

An upstream data outage may result in potential delayed or missing reporting of Severe Weather Events across Europe.
Posted Jun 07, 2026 - 20:08 UTC
This incident affected: API (Timeline API, Alerts API, Notifications API) and Web Application - Platform (Web Application, Alerts, Weather Reports).